Contact Info / Websites

Recent Movie Reviews


Phoenix Wrong -Absolutely Phoenix Wrong -Absolutely

Rated 2.5 / 5 stars

Not bad at all.

A pretty good 'Pheonix Wrong' flash. The image quality seemed to be fine and the sound selection was also pretty decent (although not knee-slapping hilarious).

The only problem I have with this (and it's just nit-picking here) is the speed of some of the sprites (mainly the gavel). Other than that, it's a pretty good flash.



Tales of Ron Pilot Tales of Ron Pilot

Rated 1 / 5 stars

Nice try for a first Flash Movie...

First and foremost, the voice acting needs to be a hell of a lot better. I know you were trying to go for the 'deep, voice-over guy' effect, but in this case it was poorly done and could barely be understood.

Your drawing style is pretty good. My only problem is that you didn't use it effectively. What's the point of having decent drawings if you're not going to bring them to life? A little walking animation, a simple arm movement, anything would have been better than whole static images being moved across the screen with motion tweens.

For a first Flash Movie, it's ok. It definitely could use a lot of improvements.



Dad's at Work Dad's at Work

Rated 5 / 5 stars

*Claps*

Oh how I missed Dad and his wacky antics.

There really isn't much that I can say that hasn't already been said. Animation style is good and at least consistent with Dad's Home, and the music choice was just excellent.

I can't wait to see the next installment. Good work!


Recent Game Reviews


Wiggminton Wiggminton

Rated 4.5 / 5 stars

Awesome

I was quite entertained! Graphical style is excellent, sound is awesome, and the controls are quite unique. If only I could try this out with my Wiimote.

Excellent work!



MadPac 3 Underwater MadPac 3 Underwater

Rated 1.5 / 5 stars

Pretty Decent

That being said though, I encountered a problem with the third level. I couldn't move at all.

Your introduction could also use some work. It doesn't automatically go to the main menu after it's done. A simple gotoAndPlay will fix this.


adi4x responds:

Fixed Level 3 Bug. It was something like _root.speed = 0 :)

Thank you all!